+44 0330 223 3428
Call Us
+44 0330 223 3428

WPTavern: Let’s Encrypt Wildcard Certificates Are Now Available

WPTavern: Let’s Encrypt Wildcard Certificates Are Now Available

In July of last year, Let’s Encrypt announced that it would begin issuing Wildcard certificates for free in January of 2018. Although a little late, the organization has announced that Wildcard certificate support is now live.

In addition to these certificates, the organization has updated its ACME protocol to version 2.0. ACMEv2 is required for clients that want to use Wildcard certificates.

Wildcard certificates enable site administrators to secure all sub domains with a single certificate. This can be especially convenient for WordPress Multi-site networks.

Let’s Encrypt is working on transitioning all clients and subscribers to ACMEv2, though it hasn’t set a time table on when it will expire the ACMEv1 API.

In July of 2017, Let’s Encrypt was securing 47 million domains. Today, the organization is securing nearly 70 million domains with 54 million certificates. In the United States, nearly 80% of sites loaded in Firefox are through HTTPS.

Let’s Encrypt is an open certificate authority that’s part of the non-profit Internet Security Research Group. It’s mission is to make 100% of the web HTTPS. Operations are financed through sponsors and donations. If this is a mission you believe in, please consider donating to the project.



Source: WordPress

Related Post
WPTavern: Matt Mullenweg Publishes TED Talk on the Future of Work, Prepares to Launch New Distributed.blog Website

WPTavern: Matt Mullenweg Publishes TED Talk on the Future of Work, Prepares to Launch New Distributed.blog Website Matt Mullenweg is teasing out a new website at distributed.blog with the tagline “The future of work is here.” It’s not clear yet whether subscribers to the mystery blog will be on board for blog posts, a new […]

Read more
WPTavern: WPBrigade Patches Critical Vulnerability in Simple Social Buttons Plugin

WPTavern: WPBrigade Patches Critical Vulnerability in Simple Social Buttons Plugin WPBrigade, the developers behind the Simple Social Buttons plugin, have patched a critical privilege escalation vulnerability. The security issue was discovered by the team at WebARX. Developer and researcher Luka Šikić summarized the vulnerability in a post published this week: Improper application design flow, chained […]

Read more
WPTavern: WPWeekly Episode 345 – The Relationship Between Corporate Cash and Open Source Software

WPTavern: WPWeekly Episode 345 – The Relationship Between Corporate Cash and Open Source Software In this episode, John James Jacoby and I discuss a thought-provoking post published by Morten Rand-Hendriksen that takes a deep look at equity in open source software. Morten suggests that the mantra of decisions are made by those who show up […]

Read more